ATEM Streaming Bridge

Hello people

I received my ATEM Streaming Bridge today. And it works wonderfully via LAN. I cannot figure out how to stream to it from the internet. I keep getting ‘port forwarding error’ despite forwarding port 1935 as per the streaming bridge settings. I tried port forwarding multiple routers (only 2 as I only have the 2) I tried my home internet and 4g phone USB tethered travel router. I have the latest ATEM software too 8.5.2 Just wondering if anybody else has any issues. I’m in Australia so I’m not sure if many others have received theirs yet.

Just to update. I’ve had no issues getting the Streaming Bridge visible to the internet through my Google WiFi Mesh router opening up port 1935. The issue seems to be compatibility with my GL.inet Slate travel router. I still get port forwarding error. I have tried the following;

Port Forwards - Protocol TCP/UDP, External zone WAN, Ext Port 1935, Internal zone LAN, Internal IP 192.168.8.166, Int Port 1935, Enabled

Open Ports on Router - Port 1935, Protocol TCP/UDP, Status Enabled

DMZ - DMZ Host IP 192.168.8.166

OFF: when and where did you ordered from? As I’ve ordered on 1st August in UK and still no ETA .

New Media - Australia

I only just got it 3 days ago. I ordered pretty early too. Hopefully, your’s arrives soon.

Adrian

1 Like

Hey GreenMedia.

I’m having the exact same problems with a GL.inet router and couldn’t get the Streaming Bridge to port forward in my home or work network either. Did you get any clarity on the issue here?

Nope. I’ve received no suggestions or ideas. I’ve given up on it. I couldn’t get it to work with my older D-Link router either. Only works on my home Google WiFi. I need it to work in the field.
I was hoping Aaron Parecki would have some input as I think he has the same gl.inet slate router.

Yes, we use the Gl.inet routers quite a lot on set. I know many DIT use them to remotely control camera settings among other things.

I have them stuck to my Teradek cubes and also use them with Atem Minis to broadcast via tethered USB modem as well.

As such, I was hoping to use the Streaming Bridge as a simple Streaming Decoder that I can directly connect to a client monitor somewhere at unit base to receive the image from wherever we are driving around in the world. Unfortunately I haven’t gotten it online in any configuration I tried.

Local network with or without key works fine, but internet.

Tested on my home DSL router and a 4G Netgear MR1100, no luck.
Streaming Bridge didn’t appear in the UPNP list.
I’ve tried Port forward, DMZ settings as well.

Also Streaming Bridge idea it probably ok until your IP address won’t change, so 4G/5G won’t be an option for this :frowning:

My bad. For some reason the ports were closed AND Default DMZ Server IP address needed to be the Streaming Bridge’s IP address , so now looks fine.

Now my ATEM MINI PRO connects via LAN to NETGEAR M1 (MR1100) 4G router.
STREAMING BRIDGE is connected to my home broadband and receiving.

Happy days.

You should not need to use DMZ for the streaming bridge IP (unless you want the streaming bridge to be unprotected on the internet) if you are port forwarding properly to the “static” internal IP address of the streaming bridge. (Notice: assign a static LAN IP to the streaming bridge on the DHCP server of your router is key for this to work properly and everytime you turn on the streaming bridge).

Here are some sites to use for help with port forwarding depending on your router (for any port you want accessible from the Internet including the Streaming Bridge). Use port forwarding with caution as you are bypassing your router firewall protection doing this.

To help you configure your router for port forwarding (large list of router manufacturers):
https://portforward.com/router.htm

The port you will need to open is the standard RTMP port for any streaming server which is port 1935 TCP only!

If you have more than one streaming bridge, you will have to port forward additional TCP ports at the router (assuming you do not have access to multiple public IP addresses on your Internet connection) and make sure to assign a static LAN IP address for every Streaming bridge on your router and to configure each Streaming Bridge to listen to the TCP port you are forwarding to it.

Make sure you have the streaming bridge on and running before using the next site.

To test to see if the port is available on the Internet use:
https://www.canyouseeme.org/

Use 1935 and if you did everything correctly, the site will let you know.

Success: I can see your service on XXX.XXX.XXX.XXX on port ( 1935 )

Keep in mind all of the security risks involved with opening ports.

BTW, network experience in use here, no streaming bridge tested or owned as I can build the streaming server to do the same thing.

1 Like

Thanks for this helpful explanation Mike!

I’ve disabled DMZ and it’s still fine, so the port forward setting for Inbound services was right.

Thank you. Helpful explanation. This is what I did:


Router from UPC Poland: Hitron CGNV4

Just make sure that you setup a static DHCP IP for 192.168.0.27 so that this will work in the future should you ever shut off the ATEM streaming bridge or Raspberry PI or insert the machine that you want to be able to use the port in the future.

I have 4 Streaming Bridges. The first one shows up on the Internet setting “visible Worldwide”. If I connect the 2nd one, I get a “UPnP error”

They are connecting to the same network, same router, same cable. What could be the difference between the two? Any ideas?

Thanks, Paul

Hi

I have some problem with Streaming Bridge port forwarding. As you can see I (probabll) set everything as it should be. Nevertheless utility software return: “port forwarding error”. I tried to set DMZ on and off…no changes. Any idea what can I do more?