ATEM mini not preserving upstream keyer

Atem mini just arrived yesterday, so very new to it.

But i noticed despite the setting in setup. The upstream keyer is not preserved whn i switch sources on the ATEM mini itself.
Switching in the controller software preserves the upstream keyer as expected.

Is this a setting somewhere?
Am I doing somthing wrong?

(I’ll proberly switch to controlling the ATEM mini by companion, but seems a bu to me)

Hope some can help with this.

The USK is input-based, isn’t it? So it should work only with one Input at the same time…?

You need to change to Stay on with transition in the ATEM Mini Setup

But when used in the software it stays on while switching…

That is on stay with transition, i did that.